간절히 기도합니다. 세월호!!!

아이폰 5.1.1 완탈 오류

얼마 전 완탈 도구(Absinthe)가 발표됐다. 지난 1월에 5.0.1 완탈이 발표됐으니 근 5개월만에 등장한 완탈 도구다. 그런데 일부 아이폰 사용자는 완탈을 시도하면 '지원하지 않는다(Sorry, the attached device is not supported.)는 메시지가 나타난다. 그 이유는 간단하다. 애플에서 은근 슬쩍 펌웨어 판올림을 진행했기 때문이다. 따라서 아이폰 4를 사용하며 iOS 5.1판 이하를 사용하던 사용자에게는 '지원하지 않는다'는 메시지가 나타난다. 그러나 해결하는 방법은 간단하다.

탈옥 오류


석호필

탈옥의 최고 대가는 역시 프리즌 브레이크석호필이다. 만다라를 연상케하는 아주 복잡한 문신을 온몸에 새겼다. 그리고 진행되는 탈옥. 미드를 좋아하지 않는 사람들도 알고 있을 드라마라고 생각한다. 아이폰 탈옥은 석호필 탈옥 만큼 힘들지는 않지만 종종 예상치 않은 일이 발생한다.

얼마 전 iOS 5.1.1의 완탈이 발표됐다. 바로 이전 글에서 소개한 Absinthe 2.0이다. 나도 완탈이 올라온 다음 날 바로 완탈해서 사용하고 있다. 또 완탈에 대한 글을 올린 뒤 iOS 5.1.1 완탈이라는 검색어로 접근하는 방문자가 많은 것으로 봐서 '완탈을 기다린 사람들이 꽤 많았다'는 것을 알 수 있다. 모두 완탈의 등장에 기뻐하고 있을 시간에 완탈이 되지 않아 눈물 짓는 사람들도 있다. Absinthe 2.0.1을 이용해서 완탈을 시도하면 다음 그림처럼 '지원하지 않는다(Sorry, the attached device is not supported.)'는 오류가 발생하기 때문이다.

이런 오류는 아이폰 4(iPhone 4) 사용자에게만 발생한다. 다만 모든 아이폰 4 사용자에게 발생하는 것은 아니다. 나 역시 아이폰 4를 사용하고 있지만 이런 오류는 발생하지 않았다. 만약 아이폰 4를 사용하고 있으며 완탈을 시도할 때 위와 같은 오류(Sorry, the attached device is not supported.)가 뜬다면 먼저 펌웨어의 판번호(빌드)를 확인해 보기 바란다. 아마 빌드 번호가 9B208일 것이다. 정상적으로 탈옥이 된 사람들의 빌드 번호는 9B206이다.

은근한 판올림

애플은 완탈이 등장한 지난 25일 펌웨어 판올림을 진행했다. 모든 기기에 대한 판올림이 아니라 아이폰 4 사용자 중 아직 iOS 5.1.1을 설치하지 않은 사용자에 대한 판올림이다. 따라서 완탈 도구가 등장하기 전에 iOS 5.1.1로 판올림 한 사람은 이전 글에서 설명한 방법으로 완탈이 가능하다. 그러나 완탈을 기다리며 iOS 5.0.1을 고수한 사람이나 5.1과 5.1.1에 큰 차이가 없어서 5.1을 그냥 사용하던 사람들이 5월 25일 이후로 판올림을 시도하면 9B208 빌드가 설치된다. 이 때문에 25일 올라온 Absinthe 2.0.1을 실행하면 '지원하지 않는다'는 메시지가 뜬다.

다만 iOS 5.1.1이 판올림됐지만 무엇이 바뀌었는지는 애플측에서 제공하지 않고 있다. 완탈 도구가 등장한 직후 판올림이 행해졌기 때문에 완탈을 막기위한 꼼수라는 이야기도 있었다. 판올림된 부분이 무엇인지 모르기 때문에 확답하기는 힘들다. 그러나 전체적으로 보면 꼼수가 아니라 일반적인 판올림으로 보인다. 일단 완탈을 막기위한 꼼수라면 모든 장치에 대해 판올림이 있어야 한다. 그런데 판올림은 아이폰 4에 대해서만 있었다. 즉, 다른 기기는 이런 판올림이 없다는 점이다.

아울러 iOS 5.0.1아이폰 4S만 9A405에서 9A406로 단독 판올림이 있었다. 또 앞에서 설명한 것처럼 이미 9B206로 판올림한 사람들은 펌웨어 판올림 메시지가 나타나지 않는다. 즉, 완탈을 막기 위한 꼼수라면 강제 판올림이 진행되어야 하는데 그렇지 않다는 것이다. 아이폰 4를 사용하며 5.1 이하 판을 사용하다 5.1.1 완탈이 나와 펌웨어 판올림을 한 사람만 9B208로 판올림 된다. 이미 9B206을 설치한 상태라면 OTA나 아이튠즈로도 판올림되지 않는다주1

발빠른 탈옥 도구 판올림

그러나 크게 걱정할 필요는 없다. 이 부분을 수정한 Absinthe 2.0.2가 이미 올라왔기 때문이다. 즉, Absinthe 2.0.2을 이용하면 iOS 5.1.1 9B208도 탈옥할 수 있다. 2.0.2는 다음 링크에서 내려받을 수 있다. 또 탈옥하는 절차도 이전 글과 완전히 동일하다. 마지막으로 이미 9B206로 판올림한 사람이 9B208로 판올림하고 싶다면 펌웨어를 직접 내려받아 업데이트를 수동으로 판올림하면 된다. 다만 바뀐 부분이 무엇인지 모르기 때문에 사용에 지장이 없다면 그냥 사용하는 것이 낫다주2.

Absinthe 2.0.2를 실행하면 다음 그림처럼 9B208 빌드가 잘 인식되는 것을 알 수 있다. 이 상태에서 Jailbreak 단추만 클릭하면 된다.

관련 글타래
잠깐만
  1. 펌웨어를 내려받아 수동으로 설치하는 것은 가능하다. 아울러 확인을 위해 나는 9B208로 판올림한 상태다.
  2. 최근 2.0.4가 올라와 링크는 2.0.4로 교체했다.
2012/05/29 18:17 2012/05/29 18:17
글쓴이
author image
운영체제의 모든 것을 운영하고 있는 IT 블로거. IT 블로거라는 이름은 현재 시국때문에 시사 블로거로 바뀐 상태다. 그러나 나는 아직도 시사와 사회에 관심이 많은 IT 블로거일 뿐이다. 컴퓨터, 운영체제, 시사, 가족, 여행, 맛집, 리뷰등과 살면서 느끼는 소소한 일상이 블로그의 주제이다. 왼쪽의 아이콘은 둘째 딸 다예가 그린 내 모습이다.
오늘의 글
인기있는 글
컴퓨터 팁&텍
트랙백 많은 글
조회수 많은 글 | 베오베
댓글 많은 글 | 베오베

Trackback

Trackback Address :: http://offree.net/trackback/3561

Facebook

Comments

  1. iPad 2012/05/30 21:57

    iPad에서는 글들이 왜 안보일까요?

    perm. |  mod/del. reply.
    • 도아 2012/05/31 10:47

      무슨 이야기신지요? 글은 휴지통에 있어서 복구했습니다.

  2. 김민지 2012/06/06 22:13

    관리자만 볼 수 있는 댓글입니다.

    perm. |  mod/del. reply.
  3. 김혜인 2012/06/12 11:12

    관리자만 볼 수 있는 댓글입니다.

    perm. |  mod/del. reply.
  4. 박군 2012/07/22 00:21

    감사합니다 ㅠㅠ

    perm. |  mod/del. reply.
    • 도아 2012/07/31 17:54

      예전에 블로그에 자주 방문하던 분인가요?

  5. Enq 2012/09/16 22:48

    이거해도 안되면 답이없는 건가요.. 처음엔 오류보내기 떠서 안보내는거 하고 다시 했더니
    리커버리 어쩌고 뜨네요........ 전에는 탈옥 잘 됐었는데 유독 5.1.1 업데이트 후 탈옥이 되질 않네요 ㅠㅠ

    perm. |  mod/del. reply.

댓글로 탄핵 인용의 기쁨을 나눠요!

(옵션: 없으면 생략)

글을 올릴 때 [b], [i], [url], [img]와 같은 BBCode를 사용할 수 있습니다.